Dise帽o de pseudoc贸digo #1 | PSeInt 馃捇



Un pseudoc贸digo​ es una descripci贸n bien detallada, de alto nivel compacta e informal​, que nos muestra el principio operativo de un programa inform谩tico u otro algoritmo.

Para el siguiente planteamiento:

Problema pseudoc贸digo #1

Se necesita una aplicaci贸n que solicite al usuario digitar n煤meros positivos y negativos.

  • El programa debe obtener el resultado de la suma de los n煤meros positivos y el resultado de la suma de los n煤meros negativos e imprimir esos resultados.
  • El programa termina cuando el usuario digite 0.


Su desarrollo seria:

Algoritmo Problema_1
    
    //Variables definidas
    Definir num_positivo, sum_positivos, indice Como Entero;
    Definir num_negativo,sum_negativos, sum Como Real;
    
    //Variables inicializadas
    num=1;
    indice=0;
    
    //T铆tulo
    Escribir "::::::::::::::::::::::::::::::::::::::::::"
    Escribir "CONTADOR DE N脷MEROS POSITIVOS Y NEGATIVOS"
    Escribir "-----------------------------------------"
    
    //Ciclo
    Repetir
        
        //铆ndice
        indice=indice+1
        
        Escribir,indice, ") " "Ingrese un n煤mero positivo o negativo."
        Leer num
        
        Escribir "-----------------------------------------"
        
        //Condicional
        Si num0 Entonces
            num_positivo=num
            sum_positivos=sum_positivos+num_positivo
        SiNo
            si num<0 Entonces
                num_negativo=num
                sum_negativos=sum_negativos+num_negativo
            FinSi
        FinSi
        
    Hasta Que num=0
    
    //Resultados
    Escribir "*****************************************"
    Escribir "-> La suma de n煤meros positivos es:", sum_positivos
    Escribir "-> La suma de n煤meros negativos es:", sum_negativos
    Escribir "*****************************************"
    
FinAlgoritmo


Reglas de comentarios...
Recuerda ser tolerante, hablar sin insultos, no hacer spam, aportar o solicitar soluciones.

Publicar un comentario

Reglas de comentarios...
Recuerda ser tolerante, hablar sin insultos, no hacer spam, aportar o solicitar soluciones.

Dejar un comentario (0)

Art铆culo Anterior Art铆culo Siguiente